Re: R: I: STAR CASTLE PCB with a "little" problem - SOLLVED

From: Chris Leyson <cleyson_at_aol.com>
Date: Wed Jun 22 2011 - 13:44:55 EDT

Well done on finding the fault. I didn't get very far with running start
castle on my fpga board, the vectors for the start up text,
and the two space ships were all over the place. One thing I did notice
from a simulation was that the init_position pulses
are fairly short for these vectors and the time between init_position
and line_drawing pulses is about 3us.

I checked my DAC settling time with a scope and it looked OK, (serial
DAC clocked at 25MHz) so I checked the X and Y
vectors coming out of the FPGA with a logic analyser. They matched the
simulation perfectly !!. DACs are now replaced
with fast parallel parts, AD7945, and the vectors are perfect.

I got a bit sidetracked after that and started looking at Atari vector
games :-) Decided to have a go at a microcoded 6502.
So far the program counter, ALU and register bank are done, just under
70 slices on a Spartan 3. Will keep you posted.

Regards
Chris

On 22/06/2011 17:43, vernimark wrote:
>
> HP Logic Comparator... I suggest to use it with the expansion zif
> socket card
>
> I could see the gameplay was not affected by this problem, so I
> decided to start from the digital output going back, but the
> temptation to troubleshoot the CCPU was stronger than the logic so I
> began to check RAMs, ROMs, ALU and so on but everything seemed to work
> properly. Then I began again from the video output and... that's all
>
> ------------------------------------------------------------------------
>
> *From:*owner-vectorlist@vectorlist.org
> [mailto:owner-vectorlist@vectorlist.org] *On Behalf Of *John Robertson
> *Sent:* mercoledý 22 giugno 2011 18.34
> *To:* vectorlist@vectorlist.org
> *Subject:* Re: R: VECTOR: I: STAR CASTLE PCB with a "little" problem -
> SOLLVED
>
> vernimark wrote:
>
> As you know I started from this condition:
>
> http://www.youtube.com/watch?v=n9h0c9qYkZM
>
> After some checks the problem was in a faulty 74194 (4-BIT BIDIRECTIONAL
> UNIVERSAL SHIFT REGISTERS) in position N4: Secondary accumulator, logic
> block 3
>
> regards,
> vernimark
> www.vernimark.com/arcade <http://www.vernimark.com/arcade>
>
>
>
> 74194's seem to fail disproportionally over other TTL.
>
> I too would like to know who you found this one. Did you use the Cine
> box or a 'scope? A logic comparator is handy...
>
> John :-#)#
>
>
>
> -----Original Message-----
> From:owner-vectorlist@vectorlist.org <mailto:owner-vectorlist@vectorlist.org>
> [mailto:owner-vectorlist@vectorlist.org] On Behalf Of vernimark
> Sent: mercoledý 8 giugno 2011 16.43
> To:vectorlist@vectorlist.org <mailto:vectorlist@vectorlist.org>
> Subject: RE: R: VECTOR: I: STAR CASTLE PCB with a "little" problem
>
> Monitor is ok (star hawk and armor attack work well), this evening I'll
> check the PCB flat connector
>
> -----Original Message-----
> From:owner-vectorlist@vectorlist.org <mailto:owner-vectorlist@vectorlist.org>
> [mailto:owner-vectorlist@vectorlist.org] On Behalf Of Christopher X.
> Candreva
> Sent: mercoledý 8 giugno 2011 16.25
> To:vectorlist@vectorlist.org <mailto:vectorlist@vectorlist.org>
> Subject: Re: R: VECTOR: I: STAR CASTLE PCB with a "little" problem
>
> On Wed, 8 Jun 2011, vernimark wrote:
>
>
>> I'm sorry for the quality of my video, but if you look it carefully you
>>
> can see the "rings" of the castle
>
>> shake a little bit. But if you look more carefully the rings don't shake
>>
> , they are simply drawn with some
>
>> segment vertex wrong for a short time, just a "frame" (I know we don't
>>
> have frames in vector games). The same
>
>> happens with the animy starship: when it rotates in some positions and for
>>
> a very short time, some vertex are
>
>> wrong. So definitely it is not a problem limited to one object.
>> I already changed 181 TTL RAMs and ROMs
>>
>
> If it's all objects then maybe it's one of the DACs, either a stuck pin or
> just one "bit" with a desoldered pin.
>
> ==========================================================
> Chris Candreva --chris@westnet.com <mailto:chris@westnet.com> -- (914) 948-3162
> WestNet Internet Services of Westchester
> http://www.westnet.com/
>

---------------------------------------------------------------------------
** Unsubscribe, subscribe, or view the archives at http://www.vectorlist.org
** Please direct other questions, comments, or problems to chris@westnet.com
Received on Wed Jun 22 13:45:30 2011

This archive was generated by hypermail 2.1.8 : Wed Jun 22 2011 - 19:50:00 EDT